I-8024 User's Manual

Analog Output | Output Channel | 4 channels
 | Output Type | 0 ~ 20mA 4 ~ 20mA -10 ~ +10V
 | Accuracy | ±0.1% of FSR
 | Resolution | ±0.02% of FSR
 | Zero Drift | Voltage : ±30µV/ºC Current : ±0.2µA/ºC
 | Span Temperature Coefficient | ±20ppm/ºC
 | Programmable Output Slop | Not Available for Parallel Type
 | Voltage Output Driver | 5mA max
 | Current Load Capability with 24V external power | 1050 Ohms max
 | Isolation Voltage | 3000Vrms
LED Display | 1 LED as Power/Communication indicator
Power Requirement | DC +5V, 250mA maximum
Note | 8024 : Internal Parallel Bus

I-87024 Pin Assignment
Terminal Number | Pin Name
5 | Iout0
6 | AGND
7 | Iout1
8 | AGND
9 | Iout2
10 | AGND
11 | Iout3
12 | AGND
13 | Vout0
14 | AGND
15 | Vout1
16 | AGND
17 | Vout2
18 | AGND
19 | Vout3
20 | AGND

I-8024 Block Diagram

Voltage Output Wiring | I-87024 Voltage Output Wiring
Current Output Wiring | I-87024 Current Output Wiring
Screw wire into I-8024 | Screw wire into I-87024

I-87024 Dimention

Back to Previous Page


I-8024 Slave Command Sets

Command | Description
$AASiCjARRFF | Configuration
$AASiCjB | Configuration Status
#AASiCj(data) | Analog Data Output
$AASiCj0 | 4mA Calibration
$AASiCj1 | 20mA Calibration
$AASiCj3HH | Trim Calibration
$AASiCj4 | Power On Voltage/Current Value
$AASiCj6 | Last Value ReadBack


I-8000 Command Sets

Command | $AASiCjARRFF
Description | This command set the analog data output module that output range, data format and slew rate for the specified channel and slot in the I-8000 system.
Syntax $AASiCjARRFF[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
A | Command for set the output range, data format of the analog output module
RR | Input range code Type
FF | Data format code Format
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S0C1A3300
Response | !01(cr)
Description | This example set the channel 2,slot 0 in the I-8000 system at address 01h with +/-10V output range, immediate change and engineering unit data format. The response indicates the command is valid.
Modules | I-87024,I-8024


Command | $AASiCjB
Description | Read the Analog Data Output module configuration from the specified Slot and channel in the I-8000 system.
Syntax $AASiCjB[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
B | command for read Analog data output module configuration
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AARRFF[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
RR | Input range code Type
FF | Data format code Format
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S1C0B
Response | !013300(cr)
Description | The Analog Data output Module in slot 1 of the I-8000 system at address 01h ,that a output range +/-10V, data format is engineering unit, slew rate is immediate change.
Modules | I-87024,I8024


Command | #AASiCj(data)
Description | Send the Value to the analog data output module in the specified channel and slot of the I-8000 system. The data format is engineering units only.
Syntax #AASiCj(data)[CHK](cr)
# | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
(data) | decimal value, always engineer unit
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !(data)[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
(data) | Return from RTD input module in engineering.
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | #01S3C109.000
Response | >(cr)
Description | This example send the value +9.000V to Analog Data output Module in slot 3 and channel 1 of the I-8000 system at address 01h The response indicates the command is valid.
Modules | I-87024,I-8024


Command | $AASiCj0
Description | Implement the analog output module 0mA calibration in the specified slot and channel of the I-8000 system.
Syntax $AASiCj0[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
0 | command for span calibration
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Note:
Do not use this command until you really understand this command.
Before use this calibration command,You must trim the correct value use trim calibration command.refer to Trim command

Example
Command | $01S1C20
Response | !01(cr)
Description | This command implement 0mA calibration in the slot1 and channel 2 of the I-8000 system at address 01h.The response indicates the command is valid.
Modules | I-87024,I-8024


Command | $AASiCj1
Description | This command to implement the Analog Data output module 20mA calibration in the specified Slot and channel of the I-8000 system.
Syntax $AASiCj1[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
1 | command for zero calibration
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Note:
Do not use this command until you really understand this command.
Before use this calibration command,You must trim the correct value use trim calibration command.refer to Trim command

Example
Command | $01S21
Response | !01(cr)
Description | The response indicates the command is valid.
Modules | I-87024,I-8024


Command | $AASiCj3HH
Description | This command to implement the Analog Data output module trim calibration in the specified Slot and channel of the I-8000 system.
Syntax $AASiCj3HH[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
3 | command for trim counts
HH | HEX Trim value by counts 00 to 5F = 0 to +95 counts A1 to FF = -95 to -1 counts
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | >(data)[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
> | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Note:
Do not use this command until you really understand this command.
Before trim calibration,You must equip a precision MA meter.Connect this meter to which channel you want to calibration.When you finish the calibration, Send the 4mA or 20mA calibration command to save this trim value.

Example
Command | $01S1C0314
Response | !01(cr)
Description | This example implement to increase 14h counts in the slot 1 and channel 0 of the I-8000 system at address 01h. The response indicates the command is valid.
Modules | I-87024,I-8024


Command | $AASiCj4
Description | This command set the Analog Data Output module Start up configuration for the specified Slot and channel in the I-8000 system.
Syntax $AASiCj4[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
4 | command for Set start up configuration
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S1C04
Response | !01(cr)
Description | The Analog Data output Module in slot 1 of the I-8000 system at address 01h that set the last value for the start up configuration.
Modules | I-87024,I8024


Command | $AASiCj6
Description | This command read the last value of the analog data output module in the specified slot and channel of the I-8000 system.
Syntax $AASiCj6[CHK](cr)
$ | a delimiter character
AA | 2-characters HEX module address for the specified I-8000 system ,Range from 01 to FFh
Si | Specified slot number. i = 0 to 3(4 slots) or i = 0 to 7(8 slots)
Cj | specified channel number. j = 0 to 3
6 | command for read last value
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of command
Response
Valid Command | !AA(data)[chk](cr)
Invalid Command | ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
AA | 2-characters HEX module address
(data) | Last value readback
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of response
Example
Command | $01S1C26
Response | !0109.000(cr)
Description | This example to read the last value from the slot 1 and channel 2 of the I-8000 system at address 01h.
Modules | I-87024,I-8024


Command/Response String and Checksum
Command/Response Format
Command Format | (Leading)(Address)(Command)[CHK](cr)
Response Format | (Leading)(Address)(Response)[CHK](cr)

(Leading) | Leading character, like ~, $, #, @, %, !, ?, >.
(Address) | Address of specificed module, from 00 to FF. For some command like #**, the address is ** for all modules.
(Command/Response) | Command with parameters or response with data.
[CHK] | 2-character checksum. If the CheckSum is disabled, no [CHK] here.
(cr) | end-of-command character, character return(0Dh)

Calculate Checksum
  1. Calculate ASCII sum of all characters of (Leading), (Address) and (Command)(or (Response)).
  2. Mask the sum of string with 0ffh, or said only take the last 2 digits of the hex value of the sum.
    For example, if the sum is 01BCh, take the "BC" as the [CHK].

Example
  • Command string : $012
    1. Sum of string = `$'+`0'+`1'+`2' = 24h+30h+31h+32h = B7h

    2. The checksum is B7h, and [CHK] = "B7"

    3. Command string with checksum : $012B7(cr)

  • Response string : !01070600
    1. Sum of string : `!'+`0'+`1'+`0'+`7'+`0'+`6'+`0'+`0' =
      21h + 30h + 31h + 30h + 37h + 30h + 36h + 30h + 30h = 1AFh

    2. The checksum is AFh, and [CHK] = "AF"

    3. Response string with checksum : !01070600AF
      4. (cr)


Format Selection
Analog Input Module | I-87013, I-87015, I-87015T, I-87017 , I-87018
Analog Output Module | I-87022, I-87026, I-87024
Digital Input/Output Module | I-870xx
Counter/Frequency Input Module | I-87082

Back to Previous Page

Format Table for Analog Input Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Filter Selection | CheckSum Selection | Not Used | Not Used | Not Used | Not Used | Data Format Selection

Filter Selection | 0 = 60Hz rejection
 | 1 = 50Hz rejection
 | This setting is reserved for the I-87015/I-87015T and should be zero.
CheckSum Selection | 0 = CheckSum disable
 | 1 = CheckSum enable
Data Format Selection | 00 = Engineer Unit Format
 | 01 = % of FSR Format
 | 10 = 2's Complement Hexdecimal Format
 | 11 = Ohms in Engineer Unit Format For I-87013 Only

Example
Format Code | Description
00 | 60Hz rejection, CheckSum disabled, engineer unit format
41 | 60Hz rejection, CheckSum enabled, % of FSR format
82 | 50Hz rejection, CheckSum disabled, 2's complement hexdecimal format

Back to Previous Page

Format Table for Analog Output Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Slew Rate Control |  |  |  | Data Format Selection

CheckSum Selection | 0 = CheckSum disable
 | 1 = CheckSum enable
Slew Rate Control ( For 87022/26 ) | Set to 0.
Slew Rate Control ( For 87024 ) | 0000 = Immediate output
 | 0001 = 0.0625V/Second or 0.125mA/Second
 | 0010 = 0.125V/Second or 0.25mA/Second
 | 0011 = 0.25V/Second or 0.5mA/Second
 | 0100 = 0.5V/Second or 1.0mA/Second
 | 0101 = 1.0V/Second or 2.0mA/Second
 | 0110 = 2.0V/Second or 4.0mA/Second
 | 0111 = 4.0V/Second or 8.0mA/Second
 | 1000 = 8.0V/Second or 16.0mA/Second
 | 1001 = 16.0V/Second or 32.0mA/Second
 | 1010 = 32.0V/Second or 64.0mA/Second
 | 1011 = 64.0V/Second or 128.0mA/Second
 | 1100 = 128.0V/Second or 256.0mA/Second
 | 1101 = 256.0V/Second or 512.0mA/Second
 | 1110 = 512.0V/Second or 1024.0mA/Second
 | 1111 = 1024.0V/Second or 2048.0mA/Second
Data Format Selection | 00 = Engineer Unit Format

Example
Format Code | Description
00 | CheckSum disabled, immediate output, engineer unit format
44 | CheckSum enabled, 0.0625V/Second or 0.125mA/Second output slew rate, engineer unit format
10 | CheckSum disabled, 0.5V/Second or 0.25mA/Second output slew rate, engineer unit format

Back to Previous Page

Format Table for Digital Input/Output Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Not Used | Not Used | Not Used | Not Used | Not Used | Not Used

CheckSum Selection 0 = CheckSum disable
1 = CheckSum enable

Format Table for Counter/Frequency Input Module
Bit Location | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Description | Not Used | CheckSum Selection | Not Used | Not Used | Not Used | Frequency Gate Time | Not Used | Not Used

CheckSum Selection 0 = CheckSum disable
1 = CheckSum enable

Frequency Gate Time 0 = 0.1 Second
1 = 1.0 Second


I-8000Series User's Manual

On-Line User's Manual Master And Slave
Item | Description
Slave In the slave mode the I-8000 Series can be controlled by the host machine as a distributed I/O front ends.It receive the command from the host by the comunication port, then explain the command and execute the command. So it waste the time to receive command,explain command and echo result.It can't be use for the control that must take care of the timing.
It advantage is easy to use, user doesn't take care of the hardware structure. The user only need to know how the command work.
Master | In the Master mode the I-8000 Series can operate as an embedded application. The user must write himself application program and download into main control unit.
What is MASTER/SLAVE of I-8000 Series ? The 8K485.EXE is a SLAVE firmware, it can be download into the main control unit & make it act as a SLAVE device similar to 7000 series. When the I-8000 series(8410/8810) is shipping, it is download with AUTOEXEC.BAT & 8K485.EXE.So the I-8000 series(8410/8810) will automatically execute the 8K485.EXE when the power is applied (INIT* pin OPEN). When the 8410/8810 execute the 8K485.EXE, it is a SLAVE device. If the INIT* pin & INIT* COM pin are short together,user can download new user program into 8410/8810 to make it act as a MASTER device.
When the 8411/8811 is shipping, it is master.Only the MIniOS7 in the main control unit.
How to change the 8410/8810 to a MASTER device ? The working steps are giving as following:
  • step 1: short the INIT* pin & INIT*COM pin together
  • step 2: power up & download user's application program & AUTOEXEC.BAT into 8410/8810
  • step 3: power down & open the INIT* pin
  • step 4: power up, the 8410/8810 will start to execute user's program & act as a MASTER device.
How to change the 8411/8811 to a Slave device ? The working steps are giving as following:
  • step 1: short the INIT* pin & INIT*COM pin together
  • step 2: power up & download 87K485.EXE & AUTOEXEC.BAT into 8411/8811
  • step 3: power down & open the INIT* pin
  • step 4: power up, the 8411/8811 will start to execute 87K485.EXE & act as a SLAVE device.


Type Selection
Module | Available Type
I-87013 | RTD Input
I-87015 | RTD Input
I-87015_T | Thermister Input
I-87017 | mV, V or Current Input
I-87018 | mV, V or Current Input Thermocouple Input
I-87022 | Analog Output
I-87024 | Analog Output
I-87026 | Analog Output
I-870xx | Digital Input/Output
I-87082 | Counter/Frequency Measurement

Back to Previous Page

Type 00 to 06 Definition
Type Code | Input Range | Data Format | Full Scale | Zero | Negative Full Scale
00 | -15mV to +15mV | Engineer Unit | +15.000 | +00.000 | -15.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
01 | -50mV to +50mV | Engineer Unit | +50.000 | +00.000 | -50.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
02 | -100mV to +100mV | Engineer Unit | +100.00 | +000.00 | -100.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
03 | -500mV to +500mV | Engineer Unit | +500.00 | +000.00 | -500.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
04 | -1V to +1V | Engineer Unit | +1.0000 | +0.0000 | -1.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
05 | -2.5V to +2.5V | Engineer Unit | +2.5000 | +0.0000 | -2.5000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
06 | -20mA to +20mA with 125 ohms resistor | Engineer Unit | +20.000 | +00.0000 | -20.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000

Back to Previous Page

Type 08 to 0D Definition
Type Code | Input Range | Data Format | Full Scale | Zero | Negative Full Scale
08 | -10V to +10V | Engineer Unit | +10.000 | +00.000 | -10.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
09 | -5V to +5V | Engineer Unit | +5.0000 | +0.0000 | -5.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0A | -1V to +1V | Engineer Unit | +1.0000 | +0.0000 | -1.0000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0B | -500mV to +500mV | Engineer Unit | +500.00 | +000.00 | -500.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0C | -150mV to +150mV | Engineer Unit | +150.00 | +000.00 | -150.00
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000
0D | -20mA to +20mA with 125 ohms resistor | Engineer Unit | +20.000 | +00.0000 | -20.000
 |  | % of FSR | +100.00 | +000.00 | -100.00
 |  | 2's Complement HEX | 7FFF | 0000 | 8000

Back to Previous Page

Thermocouple Type Definition
Type Code | Thermocouple Type | Data Format | Max Value | Min Value
0E | J Type | Engineer Unit | +760.00 | -210.00
 |  | % of FSR | +100.00 | -027.63
 |  | 2's Complement HEX | 7FFF | DCA2
0F | K Type | Engineer Unit | +1372.0 | -0270.0
 |  | % of FSR | +100.00 | -019.68
 |  | 2's Complement HEX | 7FFF | E6D0
10 | T Type | Engineer Unit | +400.00 | -270.00
 |  | % of FSR | +100.00 | -067.50
 |  | 2's Complement HEX | 7FFF | A99A
11 | E Type | Engineer Unit | +1000.0 | -0270.0
 |  | % of FSR | +100.00 | -027.00
 |  | 2's Complement HEX | 7FFF | DD71
12 | R Type | Engineer Unit | +1768.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
13 | S Type | Engineer Unit | +1768.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
14 | B Type | Engineer Unit | +1820.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
15 | N Type | Engineer Unit | +1300.0 | -0270.0
 |  | % of FSR | +100.00 | -020.77
 |  | 2's Complement HEX | 7FFF | E56B
16 | C Type | Engineer Unit | +2320.0 | +0000.0
 |  | % of FSR | +100.00 | +000.00
 |  | 2's Complement HEX | 7FFF | 0000
17 | L Type | Engineer Unit | +800.00 | -200.00
 |  | % of FSR | +100.00 | -025.00
 |  | 2's Complement HEX | 7FFF | E000
18 | M Type | Engineer Unit | +100.00 | -200.00
 |  | % of FSR | +050.00 | -100.00
 |  | 2's Complement HEX | 4000 | 8000
19 | L Type DIN43710 | Engineer Unit | +900.00 | -200.00
 |  | % of FSR | +100.00 | -022.22
 |  | 2's Complement HEX | 7FFF | E38F

Thermocouple Input Type Over/Under Range Response
Data Format | Over Range | Under Range
Engineer Unit | +9999 | -0000
% of FSR | +9999 | -0000
2's Complement HEX | 7FFF | 8000

Back to Previous Page

RTD Type Definition
Type Code | RTD Type | Data Format | Max Value | Min Value
20 | Platinum 100 a = 0.00385 -100 to 100 degree Celsius | Engineer Unit | +100.00 | -100.00
 |  | % of FSR | +100.00 | -100.00
 |  | 2's complement HEX | 7FFF | 8000
 |  | Ohm | +138.50 | +060.25
21 | Platinum 100 a = 0.00385 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +138.50 | +100.00
22 | Platinum 100 a = 0.00385 0 to 200 degree Celsius | Engineer Unit | +200.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +175.84 | +100.00
23 | Platinum 100 a = 0.00385 0 to 600 degree Celsius | Engineer Unit | +600.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +313.59 | +100.00
24 | Platinum 100 a = 0.003916 -100 to 100 degree Celsius | Engineer Unit | +100.00 | -100.00
 |  | % of FSR | +100.00 | -100.00
 |  | 2's complement HEX | 7FFF | 8000
 |  | Ohm | +139.16 | +059.58
25 | Platinum 100 a = 0.003916 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +139.16 | +100.00
26 | Platinum 100 a = 0.003916 0 to 200 degree Celsius | Engineer Unit | +200.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +177.13 | +100.00
27 | Platinum 100 a = 0.003916 0 to 600 degree Celsius | Engineer Unit | +600.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +317.28 | +100.00
28 | Nickel 120 -80 to 100 degree Celsius | Engineer Unit | +100.00 | -080.00
 |  | % of FSR | +100.00 | -080.00
 |  | 2's complement HEX | 7FFF | 999A
 |  | Ohm | +200.64 | +120.60
29 | Nickel 120 0 to 100 degree Celsius | Engineer Unit | +100.00 | +000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +200.64 | +120.60
2A | Platinum 1000 a = 0.00385 -200 to 600 degree Celsius | Engineer Unit () | +600.00 | -200.00
 |  | % of FSR | +100.00 | -033.33
 |  | 2's complement HEX | 7FFF | D556
 |  | Ohm | +3137.1 | +0185.2
2B | Cu 100 a = 0.00421 -20 to 150 degree Celsius | Engineer Unit () | +150.00 | -020.00
 |  | % of FSR | +100.00 | -013.33
 |  | 2's complement HEX | 7FFF | EEEF
 |  | Ohm | +163.17 | +091.56
2C | Cu 100 a = 0.00421 0 to 200 degree Celsius | Engineer Unit () | +200.00 | -000.00
 |  | % of FSR | +100.00 | -000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +167.75 | +090.34
2D | Cu 1000 a = 0.00421 -20 to 150 degree Celsius | Engineer Unit () | +150.00 | -020.00
 |  | % of FSR | +100.00 | -013.33
 |  | 2's complement HEX | 7FFF | EEEF
 |  | Ohm | +1631.7 | +0915.6

Note :
1.Type 2B, 2C and 2D are only used in the I-87015

RTD Input Type Over/Under Range Response
For I-87013 |  |
Data Format | Over Range | Under Range
Engineer Unit | +9999 | -0000
% of FSR | +9999 | -0000
2's Complement HEX | 7FFF | 8000
For I-87015 |  |
Data Format | Over Range | Under Range
Engineer Unit | +999.99 | -999.99
% of FSR | +999.99 | -999.99
2's Complement HEX | 7FFF | 8000

Back to Previous Page

Thermistor Type Definition
60 | Precon -- ST-A3 -30 to 240 degree Fahrenheit | Engineer Unit | +240.00 | -030.00
 |  | % of FSR | +100.00 | -012.50
 |  | 2's complement HEX | 7FFF | F000
 |  | Ohm | +000539.4 | +173600.0
61 | Type u Fenwell -50 to 150 degree Celisus | Engineer Unit | +150.00 | -050.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | D556
 |  | Ohm | +000037.2 | +134020.0
62 | Type u Fenwell 0 to 150 degree Celisus | Engineer Unit | +150.00 | -000.00
 |  | % of FSR | +100.00 | +000.00
 |  | 2's complement HEX | 7FFF | 0000
 |  | Ohm | +000037.2 | +006530.0

Thermistor Input Type Over/Under Range Response
For I-87015T |  |
Data Format | Over Range | Under Range
Engineer Unit | +999.99 | -999.99
% of FSR | +999.99 | -999.99
2's Complement HEX | 7FFF | 8000

Back to Previous Page

Analog Output Type Definition
Type Code | Output Range | Data Format | Max Value | Min Value
30 | 0 to 20mA | Engineer Unit | +20.000 | +00.000
31 | 4 to 20mA | Engineer Unit | +20.000 | +04.000
32 | 0 to 10V | Engineer Unit | +10.000 | +00.000
33 | -10 to 10V | Engineer Unit | +10.000 | -10.000
34 | 0 to 5V | Engineer Unit | +05.000 | +00.000
35 | -5 to 5V | Engineer Unit | +05.000 | -05.000

Back to Previous Page

I-87022 Analog Output Type Definition (T)
Type Code | Output Range | Data Format | Max Value | Min Value
0 | 0 to 20mA | Engineer Unit | 20.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000
1 | 4 to 20mA | Engineer Unit | 20.000 | 04.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000
2 | 0 to 10V | Engineer Unit | 10.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFF | 000

Back to Previous Page

I-87026 Analog Output Type Definition (T)
Type Code | Output Range | Data Format | Max Value | Min Value
0 | 0 to 20mA | Engineer Unit | 20.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000
1 | 4 to 20mA | Engineer Unit | 20.000 | 04.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000
2 | 0 to 10V | Engineer Unit | 10.000 | 00.000
 |  | % of FSR | +100.00 | +000.00
 |  | Hexadecimal | FFFF | 0000

Back to Previous Page

I-87022 and I-87026 Slew Rate Control Definition (S)

Slew Rate Control Code
( For I-87022/26 ) 		0 = Immediate output
1 = 0.0625V/Second or 0.125mA/Second
2 = 0.125V/Second or 0.25mA/Second
3 = 0.25V/Second or 0.5mA/Second
4 = 0.5V/Second or 1.0mA/Second
5 = 1.0V/Second or 2.0mA/Second
6 = 2.0V/Second or 4.0mA/Second
7 = 4.0V/Second or 8.0mA/Second
8 = 8.0V/Second or 16.0mA/Second
9 = 16.0V/Second or 32.0mA/Second
A = 32.0V/Second or 64.0mA/Second
B = 64.0V/Second or 128.0mA/Second
C = 128.0V/Second or 256.0mA/Second
D = 256.0V/Second or 512.0mA/Second
E = 512.0V/Second or 1024.0mA/Second

Back to Previous Page

Digital Input/Output Type Definition
Type Code | Description
40 | Digital Input/Output

Counter/Frequency Type Definition
Type Code | Description
50 | Counter Mode
51 | Frequency Measurement